Back to overview
Degraded

Server Maintenance

Feb 15 at 07:52pm GMT
Affected services
Hencoin API
Indigo Massage API

Resolved
Feb 23 at 08:07pm GMT

Server load has been returned to normal and services are back and reliable

Created
Feb 15 at 07:52pm GMT

Server maintenance is in progress and may result in slow speeds or short outages.